summaryrefslogtreecommitdiffstats
path: root/ax25mond/Makefile.am
diff options
context:
space:
mode:
authorRalf Baechle <ralf@linux-mips.org>2011-12-11 23:00:10 +0000
committerRalf Baechle <ralf@linux-mips.org>2011-12-11 23:00:10 +0000
commite62afa7359d9734e57a843beac68cea138fd19cc (patch)
tree1924778e00b310b4d06ec7aa8d4d7a484482b900 /ax25mond/Makefile.am
parent66d4d96bb168a6909d4d54a78a7e43ae1599b437 (diff)
Apply program name transformations also to remaining man page content.
The config files are unaffected; if you need to resolve a name conflict for the config files, use --sysconfdir=/etc and --localstatedir=/var.
Diffstat (limited to 'ax25mond/Makefile.am')
-rw-r--r--ax25mond/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/ax25mond/Makefile.am b/ax25mond/Makefile.am
index 6499f30..af5e061 100644
--- a/ax25mond/Makefile.am
+++ b/ax25mond/Makefile.am
@@ -5,6 +5,26 @@ man_MANS = ax25mond.8 ax25mond.conf.5
EXTRA_DIST = $(man_MANS) $(etcfiles)
+ax25mond.8: ax25mond.man
+ name_ax25mond=$$(echo call | sed -e '$(transform)') \
+ name_Ax25mond=$$(echo $$name_ax25mond | sed -r 's@^(.)@\U\1\E@') && \
+ name_AX25MOND=$$(echo $$name_ax25mond | sed -r 's@^(.*)@\U\1\E@') && \
+ sed -e "s/@@@ax25mond@@@/$$name_ax25mond/g" \
+ -e "s/@@@Ax25mond@@@/$$name_Ax25mond/g" \
+ -e "s/@@@AX25MOND@@@/$$name_AX25MOND/g" \
+ ax25mond.man > ax25mond.1.tmp && \
+ mv ax25mond.1.tmp ax25mond.1;
+
+ax25mond.conf.5: ax25mond.conf.man
+ name_ax25mond=$$(echo call | sed -e '$(transform)') \
+ name_Ax25mond=$$(echo $$name_ax25mond | sed -r 's@^(.)@\U\1\E@') && \
+ name_AX25MOND=$$(echo $$name_ax25mond | sed -r 's@^(.*)@\U\1\E@') && \
+ sed -e "s/@@@ax25mond@@@/$$name_ax25mond/g" \
+ -e "s/@@@Ax25mond@@@/$$name_Ax25mond/g" \
+ -e "s/@@@AX25MOND@@@/$$name_AX25MOND/g" \
+ ax25mond.conf.man > ax25mond.conf.5.tmp && \
+ mv ax25mond.conf.5.tmp ax25mond.conf.5;
+
ax25mond_LDADD = $(AX25_LIB)
ax25mond_SOURCES = \