summaryrefslogtreecommitdiffstats
path: root/ax25ipd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ax25ipd/Makefile.am')
-rw-r--r--ax25ipd/Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/ax25ipd/Makefile.am b/ax25ipd/Makefile.am
index 1572b25..93f90af 100644
--- a/ax25ipd/Makefile.am
+++ b/ax25ipd/Makefile.am
@@ -3,7 +3,10 @@ sbin_PROGRAMS = ax25ipd
man_MANS = ax25ipd.8 ax25ipd.conf.5
-EXTRA_DIST = $(man_MANS)
+EXTRA_DIST = $(man_MANS) $(etcfiles) $(doc_DATA)
+
+docdir = /usr/doc/ax25-apps
+doc_DATA = README.ax25ipd HISTORY.ax25ipd COPYING.ax25ipd
CFLAGS = -DUSE_TERMIO
ax25ipd_LDADD = $(AX25_LIB)
@@ -17,3 +20,19 @@ ax25ipd_SOURCES = \
ax25ipd.h \
process.c \
routing.c
+
+# Needed so that install is optional
+etcfiles = ax25ipd.conf
+installconf:
+ $(mkinstalldirs) $(DESTDIR)$(AX25_SYSCONFDIR)
+ @list='$(etcfiles)'; for p in $$list; do \
+ echo " $(INSTALL_DATA) $$p $(DESTDIR)$(AX25_SYSCONFDIR)/$$p"; \
+ $(INSTALL_DATA) $$p $(DESTDIR)$(AX25_SYSCONFDIR)/$$p; \
+ done
+
+AX25_SYSCONFDIR=$(sysconfdir)/ax25/
+AX25_LOCALSTATEDIR=$(localstatedir)/ax25/
+
+INCLUDES = -DAX25_SYSCONFDIR=\""$(AX25_SYSCONFDIR)"\" \
+ -DAX25_LOCALSTATEDIR=\""$(AX25_LOCALSTATEDIR)"\"
+