summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRalf Baechle <ralf@linux-mips.org>2017-01-26 17:13:48 +0100
committerRalf Baechle <ralf@linux-mips.org>2017-01-26 21:58:42 +0100
commitf763bc98e28fb1ed623bb746c1766c0ff8773173 (patch)
tree2f58ebe2c241aa4c753e84ef2db89c792e25dcf5 /Makefile.am
parent8854e46a50a0272578599d2fcd8d1fb363e19c38 (diff)
Don't fail when trying to remove a non-existing scm-version.h.tmp file.
This happens when the newly generated scm-version.h.tmp differs from an already existing scm-version.h or no scm-version.h exists yet, thus the scm-version.h.tmp was moved over to scm-version.h. Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 514f16d..7be7162 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,4 +21,4 @@ scm-version.h:
scm-version.h.in > scm-version.h.tmp && \
(cmp -s scm-version.h.tmp scm-version.h 2>/dev/zero || \
mv scm-version.h.tmp scm-version.h)
- rm scm-version.h.tmp
+ rm -f scm-version.h.tmp