summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRalf Baechle <ralf@linux-mips.org>2017-08-08 21:57:53 +0200
committerRalf Baechle <ralf@linux-mips.org>2017-08-08 21:57:53 +0200
commit368f2425dac3d5020c4118011e4f5eaae8b6e064 (patch)
tree544404c2f3d5bda16cbc6645df31680111d0b608 /configure.ac
parent65bb32d1c2b0b7f2c881b2c5d099f7d35e701fb1 (diff)
Make missing libutil fatal.
We could simply skip building the two programs that require libutil but since it's always available with glibc there's no point. Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f7394cb..92947d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,7 +22,7 @@ AC_SUBST(UTIL_LIB)
AC_SUBST(FLTK_LIB)
AC_CHECK_LIB(z, zlibVersion,Z_LIB="-lz",Z_LIB=)
AC_CHECK_LIB(ax25, ax25_config_load_ports, AX25_LIB="-lax25", AC_MSG_ERROR([Could not find the libax25 libraries; aborting]))
-AC_CHECK_LIB(util, openpty, UTIL_LIB="-lutil",UTIL_LIB=)
+AC_CHECK_LIB(util, openpty, UTIL_LIB="-lutil",AC_MSG_ERROR([Could not find libutil; aborting]))
AC_CHECK_LIB(GL, main, GL_LIB="-lGL",
AC_CHECK_LIB(MesaGL, main, GL_LIB="-lMesaGL", GL_LIB=, ${X_LIBS} ${X_PRE_LIBS} -lXi -lXext -lX11 ${X_EXTRA_LIBS}),${X_LIBS} ${X_PRE_LIBS} -lXi -lXext -lX11 ${X_EXTRA_LIBS})
if test -n "$GL_LIB"; then