summaryrefslogtreecommitdiffstats
path: root/tcpip/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tcpip/Makefile.am')
-rw-r--r--tcpip/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/tcpip/Makefile.am b/tcpip/Makefile.am
new file mode 100644
index 0000000..d047ac5
--- /dev/null
+++ b/tcpip/Makefile.am
@@ -0,0 +1,23 @@
+
+etcfiles = rip98.conf ttylinkd.conf
+etcdir = $(sysconfdir)/ax25
+
+installconf:
+ $(mkinstalldirs) $(DESTDIR)$(etcdir)
+ @list='$(etcfiles)'; for p in $$list; do \
+ echo " $(INSTALL_DATA) $$p $(DESTDIR)$(etcdir)/$$p"; \
+ $(INSTALL_DATA) $$p $(DESTDIR)$(etcdir)/$$p; \
+ done
+
+sbin_PROGRAMS = rip98d ttylinkd
+
+man_MANS = rip98.conf.5 rip98d.8 ttylinkd.conf.5 ttylinkd.8
+
+EXTRA_DIST = $(man_MANS) $(etcfiles)
+
+rip98d_SOURCES = \
+ rip98d.c \
+ rip98r.c \
+ rip98t.c \
+ rip98d.h
+