summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRalf Baechle <ralf@linux-mips.org>2009-06-20 23:03:32 +0000
committerRalf Baechle <ralf@linux-mips.org>2009-06-20 23:03:32 +0000
commit29b66b8ec360eea80b14e2cd2c3a4edf1309dbdb (patch)
tree1555460eccac5afd1a163f506ba387a474e006af /Makefile.am
parent9f0de7de494c86e19d3c7166e245682453154b74 (diff)
Install libc substitute headers only if really needed.
And only to the correct path.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 16 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 0ceed26..1705888 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,6 +6,16 @@ libax25ioincludedir = $(includedir)
INCLUDES = -DAX25_SYSCONFDIR=\""$(sysconfdir)/ax25/"\" \
-DAX25_LOCALSTATEDIR=\""$(localstatedir)/ax25/"\"
+if !AX25_H
+USE_LIBAX25_AX25_H = netax25/ax25.h
+endif
+if !NETROM_H
+USE_LIBAX25_NETROM_H = netrom/netrom.h
+endif
+if !ROSE_H
+USE_LIBAX25_ROSE_H = netrose/rose.h
+endif
+
nobase_libax25include_HEADERS = \
netax25/axlib.h \
netax25/axconfig.h \
@@ -14,10 +24,10 @@ nobase_libax25include_HEADERS = \
netax25/daemon.h \
netax25/ttyutils.h \
netax25/procutils.h \
- netax25/kernel_ax25.h \
- netax25/kernel_rose.h \
- netax25/kernel_netrom.h \
- netax25/mheard.h
+ netax25/mheard.h \
+ $(USE_LIBAX25_AX25_H) \
+ $(USE_LIBAX25_NETROM_H) \
+ $(USE_LIBAX25_ROSE_H)
nobase_libax25ioinclude_HEADERS = \
netax25/ax25io.h
@@ -40,8 +50,8 @@ libax25_la_SOURCES = \
netax25/rsconfig.h \
ttyutils.c \
netax25/ttyutils.h \
- netax25/kernel_ax25.h \
- netax25/kernel_rose.h
+ $(USE_LIBAX25_AX25_H) \
+ $(USE_LIBAX25_ROSE_H)
libax25io_la_SOURCES = \
ax25io.c \