summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRalf Baechle <ralf@linux-mips.org>2009-06-20 23:03:32 +0000
committerRalf Baechle <ralf@linux-mips.org>2009-06-20 23:03:32 +0000
commit29b66b8ec360eea80b14e2cd2c3a4edf1309dbdb (patch)
tree1555460eccac5afd1a163f506ba387a474e006af /configure.ac
parent9f0de7de494c86e19d3c7166e245682453154b74 (diff)
Install libc substitute headers only if really needed.
And only to the correct path.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7e56c65..2701f87 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,8 @@ if test "$has_ax25" = "yes" ; then
else
AC_MSG_RESULT(no)
fi
+AM_CONDITIONAL([AX25_H], [test "$has_ax25" = "yes"])
+
AC_MSG_CHECKING(for working netrom/netrom.h header file)
AC_HEADER_EGREP(unsigned int ndigis, netrom/netrom.h, has_netrom=yes, has_netrom=no)
if test "$has_netrom" = "yes" ; then
@@ -37,6 +39,8 @@ if test "$has_netrom" = "yes" ; then
else
AC_MSG_RESULT(no)
fi
+AM_CONDITIONAL([NETROM_H], [test "$has_netrom" = "yes"])
+
AC_MSG_CHECKING(for working netrose/rose.h header file)
AC_HEADER_EGREP(rose_facilities_struct, netrose/rose.h, has_rose=yes, has_rose=no)
if test "$has_rose" = "yes" ; then
@@ -45,6 +49,7 @@ if test "$has_rose" = "yes" ; then
else
AC_MSG_RESULT(no)
fi
+AM_CONDITIONAL([ROSE_H], [test "$has_rose" = "yes"])
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST