summaryrefslogtreecommitdiffstats
path: root/ax25mond/Makefile.am
diff options
context:
space:
mode:
authorCraig Small <csmall@enc.com.au>2001-04-10 01:57:46 +0000
committerCraig Small <csmall@enc.com.au>2001-04-10 01:57:46 +0000
commit628edceba5f1485ef7c4ef30fba93b4c0c0dd955 (patch)
treed3df0a0118e426470fce2bff0492b9d2ee06f4c7 /ax25mond/Makefile.am
parent57cf4e9453c51359d0c9af334c3dc1156ea2527a (diff)
Initial revisionax25-apps-0.0.5p2
Diffstat (limited to 'ax25mond/Makefile.am')
-rw-r--r--ax25mond/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/ax25mond/Makefile.am b/ax25mond/Makefile.am
new file mode 100644
index 0000000..4ccbdc4
--- /dev/null
+++ b/ax25mond/Makefile.am
@@ -0,0 +1,27 @@
+
+sbin_PROGRAMS = ax25mond
+
+man_MANS = ax25mond.8 ax25mond.conf.5
+
+EXTRA_DIST = $(man_MANS) $(etcfiles)
+
+ax25mond_LDADD = $(AX25_LIB)
+
+ax25mond_SOURCES = \
+ ax25mond.c
+
+# Needed so that install is optional
+etcfiles = ax25mond.conf
+installconf:
+ $(mkinstalldirs) $(DESTDIR)$(AX25_SYSCONFDIR)
+ @list='$(etcfiles)'; for p in $$list; do \
+ echo " $(INSTALL_DATA) $$p $(DESTDIR)$(AX25_SYSCONFDIR)/$$p"; \
+ $(INSTALL_DATA) $$p $(DESTDIR)$(AX25_SYSCONFDIR)/$$p; \
+ done
+
+AX25_SYSCONFDIR=$(sysconfdir)/ax25/
+AX25_LOCALSTATEDIR=$(localstatedir)/ax25/
+
+INCLUDES = -DAX25_SYSCONFDIR=\""$(AX25_SYSCONFDIR)"\" \
+ -DAX25_LOCALSTATEDIR=\""$(AX25_LOCALSTATEDIR)"\"
+