summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRalf Baechle <ralf@linux-mips.org>2015-05-17 00:56:08 +0200
committerRalf Baechle <ralf@linux-mips.org>2015-05-17 00:56:08 +0200
commitfa4d9ef122e1246ecf9c3164281e01c0e2fea464 (patch)
tree769dd1563700987df0bd2cc9fe8e43e1cc780b64 /Makefile.am
parenta87ac777a6a4c8b14fac8c151e44b49fceedb3cb (diff)
automake: Replace use of deprecated automake macro INCLUDES.
This fixes the automake warnings: 6pack/Makefile.am:10: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS') Makefile.am:9: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS') ax25/Makefile.am:26: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS') hdlcutil/Makefile.am:16: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS') kiss/Makefile.am:11: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS') netrom/Makefile.am:28: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS') rose/Makefile.am:15: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS') tcpip/Makefile.am:27: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS') INCLUDES has been deprecated since automake 1.5. Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 25f36bc..55c5745 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,8 +6,8 @@ SUBDIRS = ax25 hdlcutil kiss 6pack netrom rose tcpip user_call yamdrv dmascc
EXTRA_DIST = pathnames.h ax25-tools.spec
-INCLUDES = -DAX25_SYSCONFDIR=\""$(sysconfdir)/ax25/"\" \
- -DAX25_LOCALSTATEDIR=\""$(localstatedir)/ax25/"\"
+AM_CPPFLAGS = -DAX25_SYSCONFDIR=\""$(sysconfdir)/ax25/"\" \
+ -DAX25_LOCALSTATEDIR=\""$(localstatedir)/ax25/"\"
AX25_SYSCONFDIR=@sysconfdir@/ax25/
AX25_LOCALSTATEDIR=@localstatedir@/ax25/