summaryrefslogtreecommitdiffstats
path: root/ax25/Makefile.am
diff options
context:
space:
mode:
authorRalf Baechle <ralf@linux-mips.org>2015-05-25 23:17:55 +0200
committerRalf Baechle <ralf@linux-mips.org>2015-05-26 08:24:34 +0200
commit1905bd6c7e1123adccfd24803fea67227228d38c (patch)
tree4485963e814a2fd73495f7d4eb6121e695b4bf8c /ax25/Makefile.am
parentf3d21897916d7da89fe5936993351504e9f0bfc6 (diff)
Substitute proper paths in ax25d.conf.
Depending on the prefix configured, the default ax25d.conf file may contain incorrects paths. Generate config file using the correct sbin dir. Assume node which is not part of ax25-tools to be installed with the same prefix. Don't probe - chances are the sysadmin of a node system is going to install it after ax25-tools so we'd likely have to guess which never is a good thing. Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
Diffstat (limited to 'ax25/Makefile.am')
-rw-r--r--ax25/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/ax25/Makefile.am b/ax25/Makefile.am
index 40eac38..b6bdbe5 100644
--- a/ax25/Makefile.am
+++ b/ax25/Makefile.am
@@ -1,8 +1,17 @@
SUBDIRS = axgetput
etcfiles = ax25.profile ax25d.conf axspawn.conf rxecho.conf
+etcsrcfiles = ax25.profile ax25d.conf.in axspawn.conf rxecho.conf
+noinst_DATA = $(etcfiles)
varfiles = mheard.dat
+subst_path = sed -e 's|[@]SBINDIR[@]|$(sbindir)|' \
+ -e 's|[@]SYSCONFDIR[@]|$(sysconfdir)|'
+
+ax25d.conf: ax25d.conf.in
+ $(subst_path) < $(srcdir)/ax25d.conf.in > ax25d.conf.tmp
+ mv ax25d.conf.tmp ax25d.conf
+
installconf:
$(mkinstalldirs) $(DESTDIR)$(AX25_SYSCONFDIR)
@list='$(etcfiles)'; for p in $$list; do \
@@ -36,7 +45,8 @@ dist_man_MANS = ax25.4 ax25d.conf.5 axspawn.conf.5 rxecho.conf.5 \
-EXTRA_DIST = $(etcfiles) $(varfiles)
+CLEANFILES = ax25d.conf
+EXTRA_DIST = $(etcsrcfiles) $(varfiles)
ax25d_SOURCES = ax25d.c
axctl_SOURCES = axctl.c