summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRalf Baechle <ralf@linux-mips.org>2009-06-27 23:48:12 +0000
committerRalf Baechle <ralf@linux-mips.org>2009-06-27 23:48:12 +0000
commit8de3799b923ab0436819c95002fc191fbcca00c2 (patch)
tree61d75424536a7efcc779ee2a9296d62e8ab37b49 /configure.ac
parent234df61656b996e4d12b2bc13a48b10d29422bd0 (diff)
Add support for building rpm packages.
Now just a rpmbuild -ta <foo.tar.gz> will do.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 01dbdc7..c65509d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,5 +76,10 @@ if test "x$GCC" = "xyes"; then
fi
fi
-AC_CONFIG_FILES([netrom/Makefile tcpip/Makefile ax25/Makefile ax25/axgetput/Makefile Makefile rose/Makefile user_call/Makefile kiss/Makefile 6pack/Makefile hdlcutil/Makefile hdlcutil/fl/Makefile yamdrv/Makefile dmascc/Makefile])
+basever=$(echo $PACKAGE_VERSION | sed -e 's@-.*$@@')
+AC_SUBST(BASEVERSION, [$basever])
+extraver=$(echo $PACKAGE_VERSION | sed -e 's@@<:@^-@:>@*-@@' -e 's@-@_@')
+AC_SUBST(EXTRAVERSION, [$extraver])
+
+AC_CONFIG_FILES([netrom/Makefile tcpip/Makefile ax25/Makefile ax25/axgetput/Makefile Makefile rose/Makefile user_call/Makefile kiss/Makefile 6pack/Makefile hdlcutil/Makefile hdlcutil/fl/Makefile yamdrv/Makefile dmascc/Makefile ax25-tools.spec])
AC_OUTPUT