summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRalf Baechle <ralf@linux-mips.org>1999-06-07 10:24:56 +0200
committerRalf Baechle <ralf@linux-mips.org>1999-06-07 10:24:56 +0200
commit1b4023134b5ff6342301c8135b11df46546d2828 (patch)
tree50dc64182994ea2c13ce23919fa75e64edd4d0f0 /configure.in
parent17287576555a5c46fa23549e2e5f073660dccb70 (diff)
Import ax25-tools 0.0.2 from tarballax25-tools-0.0.2
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 10 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 4efad35..4e5dd00 100644
--- a/configure.in
+++ b/configure.in
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT(ax25/ax25d.c)
dnl For automake
-VERSION=0.0.1
+VERSION=0.0.2
PACKAGE=ax25-tools
AM_INIT_AUTOMAKE($PACKAGE,$VERSION)
@@ -16,14 +16,17 @@ AC_PROG_CC
AC_PROG_INSTALL
dnl Checks for libraries.
-AC_CHECK_LIB(z, zlibVersion)
-dnl AC_SUBST(AX25_LIB)
-dnl AC_CHECK_LIB(ax25, ax25_config_load_ports, AX25_LIB="-lax25", AX25_LIB=,-lz)
-AC_CHECK_LIB(ax25, ax25_config_load_ports,,,-lz)
+AC_SUBST(Z_LIB)
+AC_SUBST(AX25_LIB)
+AC_SUBST(AX25IO_LIB)
AC_SUBST(NCURSES_LIB)
+AC_SUBST(UTIL_LIB)
+AC_CHECK_LIB(z, zlibVersion,Z_LIB="-lz",Z_LIB=)
+AC_CHECK_LIB(ax25, ax25_config_load_ports, AX25_LIB="-lax25", AX25_LIB=)
+AC_CHECK_LIB(ax25io, axio_init, AX25IO_LIB="-lax25io", AX25IO_LIB=,lz)
AC_CHECK_LIB(ncurses, initscr,NCURSES_LIB="-lncurses",NCURSES_LIB=)
+AC_CHECK_LIB(util, openpty, UTIL_LIB="-lutil",UTIL_LIB=)
-AC_CHECK_LIB(util, openpty)
AC_PATH_XTRA
dnl Checks for header files.
@@ -31,6 +34,7 @@ AC_PATH_X
AC_HEADER_STDC
AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS(fcntl.h limits.h paths.h strings.h sys/file.h sys/ioctl.h sys/time.h syslog.h unistd.h)
+AC_CHECK_HEADERS(netax25/ax25.h netrom/netrom.h netrose/rose.h)
dnl Check for ceratin functions in header files
AC_HEADER_EGREP(ax25_fwd_struct, netax25/ax25.h, AC_DEFINE(HAVE_AX25_FWD_STRUCT))