summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRalf Baechle <ralf@linux-mips.org>2001-04-11 08:14:39 +0200
committerRalf Baechle <ralf@linux-mips.org>2001-04-11 08:14:39 +0200
commit59cfcb1d81825cc4816fc1ffddd0193f0ebec4ae (patch)
treee98dece1216a3b31d7170ae0bf0e122de1feac96 /configure.in
parent2964aba637fede36e89a3b6c4330767438a3b619 (diff)
Import ax25-tools 0.0.6 from tarballax25-tools-0.0.6
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index f6946f7..a0330ef 100644
--- a/configure.in
+++ b/configure.in
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT(ax25/ax25d.c)
dnl For automake
-VERSION=0.0.5
+VERSION=0.0.6
PACKAGE=ax25-tools
AM_INIT_AUTOMAKE($PACKAGE,$VERSION)
@@ -13,20 +13,28 @@ AM_CONFIG_HEADER(config.h)
dnl Checks for programs.
AC_PROG_AWK
AC_PROG_CC
+AC_PROG_CXX
AC_PROG_INSTALL
+dnl Check for X and set a conditional
+AC_PATH_XTRA
+AM_CONDITIONAL(HAVE_X, test -z "$no_x")
+
dnl Checks for libraries.
AC_SUBST(Z_LIB)
AC_SUBST(AX25_LIB)
AC_SUBST(AX25IO_LIB)
AC_SUBST(NCURSES_LIB)
AC_SUBST(UTIL_LIB)
+AC_SUBST(FLTK_LIB)
AC_CHECK_LIB(z, zlibVersion,Z_LIB="-lz",Z_LIB=)
AC_CHECK_LIB(ax25, ax25_config_load_ports, AX25_LIB="-lax25", AC_MSG_ERROR(Could not find the libax25 libraries; aborting))
AC_CHECK_LIB(ncurses, initscr,NCURSES_LIB="-lncurses",NCURSES_LIB=)
AC_CHECK_LIB(util, openpty, UTIL_LIB="-lutil",UTIL_LIB=)
+AC_CHECK_LIB(fltk, main, FLTK_LIB="-lfltk -lMesaGL", FLTK_LIB=,${X_LIBS} -lX11 -lXext -lMesaGL)
+
+AM_CONDITIONAL(HAVE_FLTK, test -n "$FLTK_LIB" )
-dnl AC_PATH_XTRA
dnl Checks for header files.
dnl AC_PATH_X
@@ -67,4 +75,4 @@ if test "x$GCC" = "xyes"; then
fi
fi
-AC_OUTPUT(netrom/Makefile tcpip/Makefile ax25/Makefile Makefile rose/Makefile user_call/Makefile kiss/Makefile hdlcutil/Makefile yamdrv/Makefile dmascc/Makefile)
+AC_OUTPUT(netrom/Makefile tcpip/Makefile ax25/Makefile Makefile rose/Makefile user_call/Makefile kiss/Makefile hdlcutil/Makefile hdlcutil/fl/Makefile yamdrv/Makefile dmascc/Makefile)