summaryrefslogtreecommitdiffstats
path: root/hdlcutil/Makefile.am
diff options
context:
space:
mode:
authorRalf Baechle <ralf@linux-mips.org>2001-04-11 08:14:39 +0200
committerRalf Baechle <ralf@linux-mips.org>2001-04-11 08:14:39 +0200
commit59cfcb1d81825cc4816fc1ffddd0193f0ebec4ae (patch)
treee98dece1216a3b31d7170ae0bf0e122de1feac96 /hdlcutil/Makefile.am
parent2964aba637fede36e89a3b6c4330767438a3b619 (diff)
Import ax25-tools 0.0.6 from tarballax25-tools-0.0.6
Diffstat (limited to 'hdlcutil/Makefile.am')
-rw-r--r--hdlcutil/Makefile.am35
1 files changed, 19 insertions, 16 deletions
diff --git a/hdlcutil/Makefile.am b/hdlcutil/Makefile.am
index 3584a38..19e06b5 100644
--- a/hdlcutil/Makefile.am
+++ b/hdlcutil/Makefile.am
@@ -1,24 +1,27 @@
-installconf:
+if HAVE_X
+X11_bin_programs = smdiag
+endif
-sbin_PROGRAMS = setcrystal sethdlc smmixer
+if HAVE_FLTK
+SUBDIRS = fl
+endif
-man_MANS = sethdlc.8 smmixer.8 baycom.9 hdlcdrv.9 soundmodem.9
+bin_PROGRAMS = sethdlc smmixer $(X11_bin_programs)
-EXTRA_DIST = $(man_MANS)
+sethdlc_SOURCES = sethdlc.c hdrvcomm.c hdrvcomm.h usersmdiag.h
+smmixer_SOURCES = smmixer.c hdrvcomm.c hdrvcomm.h usersmdiag.h
+smdiag_SOURCES = smdiag.c hdrvcomm.c hdrvcomm.h usersmdiag.h
-setcrystal_SOURCES = \
- setcrystal.c
+smdiag_LDADD = $(X_LIBS) -lX11 $(X_EXTRA_LIBS)
-sethdlc_SOURCES = \
- sethdlc.c \
- hdrvcomm.c \
- hdrvcomm.h \
- usersmdiag.h
+INCLUDES = -DAX25_SYSCONFDIR=\""$(AX25_SYSCONFDIR)"\" \
+ -DAX25_LOCALSTATEDIR=\""$(AX25_LOCALSTATEDIR)"\"
-smmixer_SOURCES = \
- smmixer.c \
- hdrvcomm.c \
- hdrvcomm.h \
- usersmdiag.h
+AX25_SYSCONFDIR=$(sysconfdir)/ax25/
+AX25_LOCALSTATEDIR=$(localstatedir)/ax25/
+
+man_MANS = sethdlc.8 smmixer.8 baycom.9 hdlcdrv.9 soundmodem.9 smdiag.8
+
+EXTRA_DIST = $(man_MANS)