summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 55c5745..514f16d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,3 +11,14 @@ AM_CPPFLAGS = -DAX25_SYSCONFDIR=\""$(sysconfdir)/ax25/"\" \
AX25_SYSCONFDIR=@sysconfdir@/ax25/
AX25_LOCALSTATEDIR=@localstatedir@/ax25/
+
+BUILT_SOURCES = scm-version.h
+
+.PHONY: scm-version.h
+scm-version.h:
+ sed -e 's/@RELEASE_VER@/@VERSION@/' \
+ -e 's/@SCM_VER@/'$$(./setlocalversion)'/' \
+ scm-version.h.in > scm-version.h.tmp && \
+ (cmp -s scm-version.h.tmp scm-version.h 2>/dev/zero || \
+ mv scm-version.h.tmp scm-version.h)
+ rm scm-version.h.tmp