summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index d0f7bd0..c8797c7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,14 +1,13 @@
installconf:
- @echo "**** WARNING - This will overwrite any existing files ****"
- @echo "**** WARNING - This will overwrite any existing files ****"
- @echo "**** WARNING - This will overwrite any existing files ****"
- @echo
- @echo Hit the return key to proceed, or ^C to exit.
- @read
@for app in $(SUBDIRS); do $(MAKE) -C $$app installconf; done
-SUBDIRS = ax25 hdlcutil kiss netrom rose tcpip user_call
+SUBDIRS = ax25 hdlcutil kiss netrom rose tcpip user_call yamdrv dmascc
EXTRA_DIST = pathnames.h
+INCLUDES = -DAX25_SYSCONFDIR=\""$(sysconfdir)/ax25/"\" \
+ -DAX25_LOCALSTATEDIR=\""$(localstatedir)/ax25/"\"
+
+AX25_SYSCONFDIR=@sysconfdir@/ax25/
+AX25_LOCALSTATEDIR=@localstatedir@/ax25/