summaryrefslogtreecommitdiffstats
path: root/hdlcutil/fl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hdlcutil/fl/Makefile.am')
-rw-r--r--hdlcutil/fl/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/hdlcutil/fl/Makefile.am b/hdlcutil/fl/Makefile.am
new file mode 100644
index 0000000..401ef67
--- /dev/null
+++ b/hdlcutil/fl/Makefile.am
@@ -0,0 +1,13 @@
+
+sbin_PROGRAMS = xfsmmixer xfhdlcchpar xfhdlcst xfsmdiag
+
+INCLUDES = $(X_CFLAGS) -I..
+LDFLAGS = $(X_LIBS) -lX11 $(FLTK_LIB)
+LDADD = hdrvcomm.o
+
+xfsmmixer_SOURCES = xfsmmixer.cxx xfsmmixer_main.cxx xfsmmixer.h
+xfhdlcchpar_SOURCES = xfhdlcchpar.cxx xfhdlcchpar_main.cxx xfhdlcchpar.h
+xfhdlcst_SOURCES = xfhdlcst.cxx xfhdlcst_main.cxx xfhdlcst.h
+xfsmdiag_SOURCES = xfsmdiag.cxx xfsmdiag_main.cxx xfsmdiag.h xfsmdiag_main.h
+
+hdrvcomm.o: ../hdrvcomm.o