summaryrefslogtreecommitdiffstats
path: root/rose/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'rose/Makefile.am')
-rw-r--r--rose/Makefile.am20
1 files changed, 8 insertions, 12 deletions
diff --git a/rose/Makefile.am b/rose/Makefile.am
index c806d95..5596113 100644
--- a/rose/Makefile.am
+++ b/rose/Makefile.am
@@ -1,14 +1,4 @@
-etcfiles = rsports
-etcdir = $(sysconfdir)/ax25
-
-installconf:
- $(mkinstalldirs) $(DESTDIR)$(etcdir)
- @list='$(etcfiles)'; for p in $$list; do \
- echo " $(INSTALL_DATA) $$p $(DESTDIR)$(etcdir)/$$p"; \
- $(INSTALL_DATA) $$p $(DESTDIR)$(etcdir)/$$p; \
- done
-
sbin_PROGRAMS = rsattach rsdwnlnk rsmemsiz rsparms rsuplnk
LDADD = $(AX25_LIB)
@@ -18,6 +8,12 @@ rsmemsiz_LDADD =
sbin_SCRIPTS = rsusers.sh
-man_MANS = rose.4 rsports.5 rsattach.8 rsparms.8 rsdwnlnk.8 rsuplnk.8
+man_MANS = rose.4 rsattach.8 rsparms.8 rsdwnlnk.8 rsuplnk.8
+
+EXTRA_DIST = $(man_MANS) $(sbin_SCRIPTS)
+
+INCLUDES = -DAX25_SYSCONFDIR=\""$(AX25_SYSCONFDIR)"\" \
+ -DAX25_LOCALSTATEDIR=\""$(AX25_LOCALSTATEDIR)"\"
-EXTRA_DIST = $(man_MANS) $(etcfiles) $(sbin_SCRIPTS)
+AX25_SYSCONFDIR=${sysconfdir}/ax25/
+AX25_LOCALSTATEDIR=${localstatedir}/ax25/