summaryrefslogtreecommitdiffstats
path: root/user_call/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'user_call/Makefile.am')
-rw-r--r--user_call/Makefile.am27
1 files changed, 23 insertions, 4 deletions
diff --git a/user_call/Makefile.am b/user_call/Makefile.am
index 0a176b9..24cf7d7 100644
--- a/user_call/Makefile.am
+++ b/user_call/Makefile.am
@@ -2,11 +2,30 @@
installconf:
-sbin_PROGRAMS = ax25_call netrom_call rose_call
+sbin_PROGRAMS = ax25_call netrom_call rose_call tcp_call
-man_MANS = ax25_call.8 netrom_call.8 rose_call.8
+man_MANS = ax25_call.8 netrom_call.8 rose_call.8 tcp_call.8
-EXTRA_DIST = $(man_MANS)
+docdir=${prefix}/doc/ax25-tools
+doc_DATA= README.user_call
-LDADD = $(AX25_LIB)
+EXTRA_DIST = $(man_MANS) $(doc_DATA)
+
+LDADD = $(AX25_LIB) $(Z_LIB)
+
+ax25_call_SOURCES = ax25_call.c \
+ user_io.c \
+ user_io.h
+
+netrom_call_SOURCES = netrom_call.c \
+ user_io.c \
+ user_io.h
+
+rose_call_SOURCES = rose_call.c \
+ user_io.c \
+ user_io.h
+
+tcp_call_SOURCES = tcp_call.c \
+ user_io.c \
+ user_io.h