summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRalf Baechle <ralf@linux-mips.org>1999-07-08 06:43:45 +0200
committerRalf Baechle <ralf@linux-mips.org>1999-07-08 06:43:45 +0200
commit25b07d12d92ebec03905433f2037cf5f9e757d7c (patch)
treea127f7c5990e1e73d76dedc875c94e7add72e77e /configure.in
parent9a9dc6176b5d74717c6e5b757a6d3b1dfe6604a3 (diff)
Import libax25 0.0.5 from tarballlibax25-0.0.5
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ccb6216..1348e47 100644
--- a/configure.in
+++ b/configure.in
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT(axlib.h)
AXLIB_MAJOR_VERSION=0
AXLIB_MINOR_VERSION=0
-AXLIB_MICRO_VERSION=4
+AXLIB_MICRO_VERSION=5
AXLIB_VERSION=$AXLIB_MAJOR_VERSION.$AXLIB_MINOR_VERSION.$AXLIB_MICRO_VERSION
# for automake
@@ -32,5 +32,12 @@ AC_CHECK_HEADERS(netax25/ax25.h netrom/netrom.h netrose/rose.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
+dnl Only use -Wall if we have gcc
+if test "x$GCC" = "xyes"; then
+ if test -z "`echo "$CFLAGS" | grep "\-Wall" 2> /dev/null`" ; then
+ CFLAGS="$CFLAGS -Wall"
+ fi
+fi
+
dnl Checks for library functions.
AC_OUTPUT(Makefile)