summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRalf Baechle <ralf@linux-mips.org>1999-04-10 00:44:09 +0200
committerRalf Baechle <ralf@linux-mips.org>1999-04-10 00:44:09 +0200
commit60368d2e0bd1a81c64b1a30b0819232866ccedb4 (patch)
treec147b96c7af298db90dad7ae782d9af3cc03092e /configure.in
Import ax25-lib 0.0.1 from tarballax25-lib-0.0.1
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..7d6484e
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,35 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(axlib.h)
+AXLIB_MAJOR_VERSION=0
+AXLIB_MINOR_VERSION=0
+AXLIB_MICRO_VERSION=1
+AXLIB_VERSION=$AXLIB_MAJOR_VERSION.$AXLIB_MINOR_VERSION.$AXLIB_MICRO_VERSION
+
+# for automake
+VERSION=$AXLIB_VERSION
+PACKAGE=ax25-lib
+
+AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
+AM_CONFIG_HEADER(config.h)
+
+dnl Checks for programs.
+AC_PROG_CC
+AC_PROG_GCC_TRADITIONAL
+AC_PROG_RANLIB
+AM_PROG_LIBTOOL
+
+dnl Checks for libraries.
+
+AC_FUNC_SETPGRP
+AC_TYPE_SIGNAL
+AC_CHECK_FUNCS(socket strdup strerror strspn)
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS(fcntl.h sys/file.h sys/ioctl.h unistd.h)
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+
+dnl Checks for library functions.
+AC_OUTPUT(Makefile)