summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRalf Baechle <ralf@linux-mips.org>1999-08-24 01:29:01 +0200
committerRalf Baechle <ralf@linux-mips.org>1999-08-24 01:29:01 +0200
commitf9ceba52b255476172ed5e4e3bbd89620ee9072f (patch)
tree7fc7149322f0340ba2df03669cc7063e18af73ae /configure.in
parente2364df6e013d5eaf6fe226ee6d5a36d1cd6337d (diff)
Import libax25 0.0.7 from tarballlibax25-0.0.7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in32
1 files changed, 29 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 208e3db..c34e0f9 100644
--- a/configure.in
+++ b/configure.in
@@ -2,14 +2,15 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT(axlib.h)
AXLIB_MAJOR_VERSION=0
AXLIB_MINOR_VERSION=0
-AXLIB_MICRO_VERSION=6
+AXLIB_MICRO_VERSION=7
AXLIB_VERSION=$AXLIB_MAJOR_VERSION.$AXLIB_MINOR_VERSION.$AXLIB_MICRO_VERSION
-# for automake
+dnl For automake
VERSION=$AXLIB_VERSION
PACKAGE=libax25
AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
+
AM_CONFIG_HEADER(config.h)
dnl Checks for programs.
@@ -27,7 +28,32 @@ AC_CHECK_FUNCS(socket strdup strerror strspn)
dnl Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS(fcntl.h sys/file.h sys/ioctl.h unistd.h zlib.h)
-AC_CHECK_HEADERS(netax25/ax25.h netrom/netrom.h netrose/rose.h)
+
+dnl Checks for working glibc 2.1 headers
+AC_MSG_CHECKING(for working netax25/ax25.h header file)
+AC_HEADER_EGREP(ax25_fwd_struct, netax25/ax25.h, has_ax25=yes, has_ax25=no)
+if test "$has_ax25" = "yes" ; then
+ AC_DEFINE(HAVE_NETAX25_AX25_H)
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
+AC_MSG_CHECKING(for working netrom/netrom.h header file)
+AC_HEADER_EGREP(unsigned int ndigis, netrom/netrom.h, has_netrom=yes, has_netrom=no)
+if test "$has_netrom" = "yes" ; then
+ AC_DEFINE(HAVE_NETROM_NETROM_H)
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
+AC_MSG_CHECKING(for working netrose/rose.h header file)
+AC_HEADER_EGREP(rose_facilities_struct, netrose/rose.h, has_rose=yes, has_rose=no)
+if test "$has_rose" = "yes" ; then
+ AC_DEFINE(HAVE_NETROSE_ROSE_H)
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST