summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 21 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 8fe835b..b780656 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,6 +4,9 @@ lib_LTLIBRARIES = libax25.la libax25io.la
libax25includedir = $(includedir)/netax25
libax25ioincludedir = $(includedir)/netax25
+INCLUDES = -DAX25_SYSCONFDIR=\""$(sysconfdir)/ax25/"\" \
+ -DAX25_LOCALSTATEDIR=\""$(localstatedir)/ax25/"\"
+
libax25include_HEADERS = \
axlib.h \
axconfig.h \
@@ -14,7 +17,8 @@ libax25include_HEADERS = \
procutils.h \
kernel_ax25.h \
kernel_rose.h \
- mheard.h
+ kernel_netrom.h \
+ mheard.h
libax25ioinclude_HEADERS = \
ax25io.h
@@ -44,7 +48,21 @@ libax25io_la_SOURCES = \
ax25io.c \
ax25io.h
-man_MANS = ax25.3 rose.3
+man_MANS = ax25.3 rose.3 axports.5 rsports.5 nrports.5
+
+
+EXTRA_DIST= $(man_MANS) glibc.patch $(etcfiles)
+
+AX25_SYSCONFDIR=@sysconfdir@/ax25/
+AX25_LOCALSTATEDIR=@localstatedir@/ax25/
-EXTRA_DIST= $(man_MANS) glibc.patch
+# Needed so that the install is optional
+etcdir = $(AX25_SYSCONFDIR)
+etcfiles = axports rsports nrports
+installconf:
+ $(mkinstalldirs) $(DESTDIR)$(etcdir)
+ @list='$(etcfiles)'; for p in $$list; do \
+ echo " $(INSTALL_DATA) $$p $(DESTDIR)$(etcdir)/$$p"; \
+ $(INSTALL_DATA) $$p $(DESTDIR)$(etcdir)/$$p; \
+ done