summaryrefslogtreecommitdiffstats
path: root/call/Makefile.am
diff options
context:
space:
mode:
authorRalf Baechle <ralf@linux-mips.org>2011-12-11 17:32:51 +0000
committerRalf Baechle <ralf@linux-mips.org>2011-12-11 17:32:51 +0000
commit4e1929b059c8249870e628cc4dae129cd5e18ec9 (patch)
treeb38ce38e6453748315dfdeeb384d6861392c8381 /call/Makefile.am
parentb9ac7b273b84f78355517ad6098d6359b68dab1c (diff)
Apply program name transformations also to man page content.
For now these options are just honored for the call.1 and listen.1 man pages because these days these two programs generally get renamed to avoid naming conflicts with other programs.
Diffstat (limited to 'call/Makefile.am')
-rw-r--r--call/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/call/Makefile.am b/call/Makefile.am
index 9668863..70df548 100644
--- a/call/Makefile.am
+++ b/call/Makefile.am
@@ -8,9 +8,26 @@ installconf:
bin_PROGRAMS = call
man_MANS = call.1
+CLEANFILES = call.1 call.1.tmp
EXTRA_DIST = $(man_MANS)
+call.1 : call.man
+ name_call=$$(echo call | sed -e '$(transform)') \
+ name_Call=$$(echo $$name_call | sed -r 's@^(.)@\U\1\E@') && \
+ name_CALL=$$(echo $$name_call | sed -r 's@^(.*)@\U\1\E@') && \
+ name_listen=$$(echo listen | sed -e '$(transform)') \
+ name_Listen=$$(echo $$name_listen | sed -r 's@^(.)@\U\1\E@') && \
+ name_LISTEN=$$(echo $$name_listen | sed -r 's@^(.*)@\U\1\E@') &&\
+ sed -e "s/@@@call@@@/$$name_call/g" \
+ -e "s/@@@Call@@@/$$name_Call/g" \
+ -e "s/@@@CALL@@@/$$name_CALL/g" \
+ -e "s/@@@listen@@@/$$name_listen/g" \
+ -e "s/@@@Listen@@@/$$name_Listen/g" \
+ -e "s/@@@LISTEN@@@/$$name_LISTEN/g" \
+ call.man > call.1.tmp && \
+ mv call.1.tmp call.1;
+
call_LDADD = $(NCURSES_LIB) $(AX25_LIB)
call_SOURCES = \