summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRalf Baechle <ralf@linux-mips.org>2007-01-22 01:04:23 +0000
committerRalf Baechle <ralf@linux-mips.org>2007-01-22 01:04:23 +0000
commitd144d58c947696e3e707e842e77959c3fb578084 (patch)
tree8a30c406655df1bd87a0c3c2606bd61a58b009db /configure.in
parente72236e605359028afb9bd01ca43890b74c1d868 (diff)
Regenerate all the autotools provided files - some were ancient and
would have failed on some modern systems. Sole exception is the old INSTALL file, libax25 had its own. Maybe we should drop for simplicity; it doesn't provide alot of information.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in68
1 files changed, 0 insertions, 68 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index 552f6e7..0000000
--- a/configure.in
+++ /dev/null
@@ -1,68 +0,0 @@
-dnl Process this file with autoconf to produce a configure script.
-AC_INIT(axlib.h)
-AXLIB_MAJOR_VERSION=0
-AXLIB_MINOR_VERSION=0
-AXLIB_MICRO_VERSION=11
-AXLIB_VERSION=$AXLIB_MAJOR_VERSION.$AXLIB_MINOR_VERSION.$AXLIB_MICRO_VERSION
-
-dnl For automake
-VERSION=$AXLIB_VERSION
-PACKAGE=libax25
-
-AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
-
-AM_CONFIG_HEADER(config.h)
-
-dnl Checks for programs.
-AC_PROG_CC
-AC_PROG_GCC_TRADITIONAL
-AC_PROG_LIBTOOL
-
-dnl Checks for libraries.
-
-AC_FUNC_SETPGRP
-AC_TYPE_SIGNAL
-AC_CHECK_FUNCS(socket strdup strerror strspn)
-
-dnl Checks for header files.
-AC_HEADER_STDC
-AC_CHECK_HEADERS(fcntl.h sys/file.h sys/ioctl.h unistd.h zlib.h)
-
-dnl Checks for working glibc 2.1 headers
-AC_MSG_CHECKING(for working netax25/ax25.h header file)
-AC_HEADER_EGREP(ax25_fwd_struct, netax25/ax25.h, has_ax25=yes, has_ax25=no)
-if test "$has_ax25" = "yes" ; then
- AC_DEFINE(HAVE_NETAX25_AX25_H, 1, [Define if you have a proper netax25/ax25.h header file])
- AC_MSG_RESULT(yes)
-else
- AC_MSG_RESULT(no)
-fi
-AC_MSG_CHECKING(for working netrom/netrom.h header file)
-AC_HEADER_EGREP(unsigned int ndigis, netrom/netrom.h, has_netrom=yes, has_netrom=no)
-if test "$has_netrom" = "yes" ; then
- AC_DEFINE(HAVE_NETROM_NETROM_H, 1, [Define if you have a proper netrom/netrom.h header file.])
- AC_MSG_RESULT(yes)
-else
- AC_MSG_RESULT(no)
-fi
-AC_MSG_CHECKING(for working netrose/rose.h header file)
-AC_HEADER_EGREP(rose_facilities_struct, netrose/rose.h, has_rose=yes, has_rose=no)
-if test "$has_rose" = "yes" ; then
- AC_DEFINE(HAVE_NETROSE_ROSE_H, 1, [Define if you have a proper netrose/rose.h header file.])
- AC_MSG_RESULT(yes)
-else
- AC_MSG_RESULT(no)
-fi
-
-dnl Checks for typedefs, structures, and compiler characteristics.
-AC_C_CONST
-
-dnl Only use -Wall if we have gcc
-if test "x$GCC" = "xyes"; then
- if test -z "`echo "$CFLAGS" | grep "\-Wall" 2> /dev/null`" ; then
- CFLAGS="$CFLAGS -Wall"
- fi
-fi
-
-dnl Checks for library functions.
-AC_OUTPUT(Makefile)